Ошибки в журнале

Аватар пользователя AndreyL
+1
+1
-1

Здравствуйте
Прошу помочь в следующем: обнаружил в журнале drupal'a ряд повторяющихся ошибок, которые возникают только у неавторизованных пользователей при переходе на страницу добавления комментария:

  • Warning: mb_substr() expects parameter 1 to be string, array given в функции drupal_substr() (строка 518 в файле /includes/unicode.inc).
  • Warning: strpos() expects parameter 1 to be string, array given в функции file_uri_scheme() (строка 200 в файле /includes/file.inc).
  • Warning: rawurlencode() expects parameter 1 to be string, array given в функции drupal_encode_path() (строка 640 в файле /includes/common.inc).

Как с ними бороться?
Я отношу себя к непрофессиональным "друпаловцам" - пользуюсь тем, что сделали другие. Да и образование с работой мои далеки от php, серверов и т.д., но постоянно что-то читаю по этим направлениям. Прошу помощи "знатоков".

Версия: 

Аватар пользователя kalabro
+1
+3
-1

ну, я бы отключила и посмотрела в нем ли была проблема. потом попробовала бы --dev версию.
если не помогло, то надо идти в issue queue и писать про найденный баг. если всё сложится хорошо, то следующий релиз будет исправлен, а вы накатите патч или просто откажетесь от этого модуля до поры до времени.

Вопрос: 

Аватар пользователя AndreyL
+1
+1
-1

Да, это Aggregate cache приводит к ошибкам. Отключил - сбросил кэш -> ошибки нет.
Включил - опять ошибки.
С dev модулем ошибки нет!
Спасибо!!!!

Вопрос: 

Аватар пользователя Alex Malkov
+1
+1
-1

Самое быстрое для начала - это по-очередное отключение/включение Капчи и редактора CKEditor. Соответственно попытка написать в комменты под неавторизованным пользователем. Последующая проверка журнала.
CKEditor требует к себе, как правило, большего внимания. Нужно проверять собственные настройки редактора, права пользователей, фильтры.

Вопрос: 

Аватар пользователя AndreyL
+1
0
-1

PHP Version 5.3.15
Block
CKEditor
Text CAPTCHA
Libraries
Google Plus One +1
Google CSE
Global Redirect
есть блок яндекс-редирект и яндекс-рся

Версия друпал обновлена. Модули обновлены. Также использую необновленный Global Redirect 7.x-1.4, т.к. обновленный неправильно работает с пейджером.

Вопрос: 

Аватар пользователя kalabro
+1
+1
-1

Возможно, проблема в необновленном Mollom'е или каком-то другом фильтре.
Пожалуйста, сообщите, какие модули у вас точно работают на этой станице и версию PHP на всякий случай (admin/reports/status). Есть ли необновлённые модули?

Вопрос: